Skip to content

[TSK] Correctly handle failure to connect to bootstrap server #52

Description

@alistairking

I'm not sure how to do this, but currently if one of the bootstrap servers are unavailable when starting up, libtimeseries will get stuck with errors like:

[10:35:54:483] kafka_connect: WARN: Failed to connect to Kafka. Retrying in 80 seconds
[10:35:54:575] kafka_error_callback: ERROR: Local: Broker transport failure (-195): riddler.caida.org:9092/bootstrap: Connect to ipv4#198.202.104.117:9092 failed: Connection refused
[10:35:54:575] kafka_connect: WARN: Failed to connect to Kafka. Retrying in 80 seconds
[10:35:54:601] kafka_error_callback: ERROR: Local: Broker transport failure (-195): penguin.caida.org:9092/bootstrap: Connect to ipv4#198.202.104.116:9092 failed: Connection refused
[10:35:54:601] kafka_connect: WARN: Failed to connect to Kafka. Retrying in 80 seconds
[10:35:54:757] kafka_error_callback: ERROR: Local: Broker transport failure (-195): penguin.caida.org:9092/bootstrap: Connect to ipv4#198.202.104.116:9092 failed: Connection refused
[10:35:54:757] kafka_error_callback: ERROR: Local: Broker transport failure (-195): riddler.caida.org:9092/bootstrap: Connect to ipv4#198.202.104.117:9092 failed: Connection refused
[10:35:54:757] kafka_connect: WARN: Failed to connect to Kafka. Retrying in 80 seconds

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions