Skip to content

VR Healthcheck Fails when a VPC is created, but there are no VMs created in the VPC yet. #10088

Description

@btzq
ISSUE TYPE
  • Bug Report
COMPONENT NAME
Virtual Router
CLOUDSTACK VERSION
4.19.1.1
CONFIGURATION
OS / ENVIRONMENT
SUMMARY

When a VPC is created, a VR is spawned.
But, when the VPC does not have any VMs created in it yet, the VR Healthcheck fails with the following error: webserver.service service down at last check

This gives lots of false alarms for the Cloud Operator because we cant control when the user has created a network or vm or not. The healthcheck fail should only fire if there really is an issue with the router.

STEPS TO REPRODUCE

ACTUAL RESULTS
- Create any VPC
- Create any subnet (Eg 1 Tier)
- Do not create any VM
- Monitor alerts, will see VR Healthcheck fail: webserver.service service down at last check 
EXPECTED RESULTS
- Should not fire healthcheck fail unless there is a real issue.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

Type

No type

Projects

No projects

    Milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions