Repository navigation
chore(deps): update dependency libressl/portable to v4.4.0 - #315
Open
renovate[bot] wants to merge 1 commit into
Open
renovate[bot] wants to merge 1 commit into
renovate[bot] wants to merge 1 commit into
Conversation
renovate
Bot
force-pushed
the
renovate/libressl-portable-4.x
branch
from
April 19, 2026 08:33
d5be692 to
861581b
Compare
renovate
Bot
force-pushed
the
renovate/libressl-portable-4.x
branch
from
May 14, 2026 18:05
861581b to
54c3b32
Compare
|
renovate
Bot
force-pushed
the
renovate/libressl-portable-4.x
branch
from
May 26, 2026 05:12
54c3b32 to
a9aca38
Compare
|
renovate
Bot
force-pushed
the
renovate/libressl-portable-4.x
branch
from
September 7, 2026 22:27
a9aca38 to
0c4dca4
Compare
|
renovate
Bot
force-pushed
the
renovate/libressl-portable-4.x
branch
from
October 5, 2026 20:38
0c4dca4 to
dd0d195
Compare
renovate
Bot
force-pushed
the
renovate/libressl-portable-4.x
branch
from
October 23, 2026 20:48
dd0d195 to
30c341a
Compare
|
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.



This PR contains the following updates:
v4.2.1→v4.4.0Release Notes
libressl/portable
v4.4.0Compare Source
Security fix: Removed eMudhra emSign ECC Root CA - G3 from cert.pem
because of weak keys of some subordinate CAs. For purposes of
interoperability, uncompromised intermediates were added.
Upgrade note: Reinstalls no longer overwrite cert.pem, so this may
need a manual merge if your package manager does not take care of
this. 'CN=emSign ECC Root CA - G3' should not appear in cert.pem.
The versioning scheme has changed slightly
API and ABI won't change.
Portable changes
that do not define BYTE_ORDER.
constant-time bignum code.
detected as 64-bit, such as "NMake Makefiles".
and linker flags as the autotools build.
CFLAGS/LDFLAGS.
absolute path.
allow overriding TLS_DEFAULT_CA_FILE in CMake builds.
openssl.cnf and x509v3.cnf.
FreeBSD and NetBSD releases with weakly seeded arc4random.
pledge and unveil on hosts that provide them.
rather than silently ignoring it.
corruption in DTLSv1_get_timeout() and the datagram BIO
timeout controls.
returning early, reports failed connects as POLLERR and
returns errors instead of timeouts. This fixes openssl(1)
s_client, s_server and ocsp spinning or missing errors.
fixing tls_load_file() with a password.
close-on-exec on the right handle.
in getprogname().
Internal improvements
of TLSv1.0 and TLSv1.1.
modern X.509 verifier.
thisUpdate to match BoringSSL and OpenSSL behavior.
asserting.
algorithm.
legacy stack.
Compatibility changes
be removed in a future release. tls_peer_cert_chain_verified_pem()
and tls_peer_cert_bundle_unverified_pem() should be used instead.
in libtls.
stop NUL-terminating ASN.1 strings. This is an old bug in libtls
that will bite, probably starting with OpenSSL 4.2.
safe and the actual cleanup is now done by OPENSSL_cleanup().
documented that it only works after calling X509_check_purpose(),
it still makes sense to "fail closed", i.e., indicate a non-CA.
and communityDefinition.
Bug fixes
on failure rather than risking a double free.
code to avoid branching on uninitialized memory.
hash to ensure identical framing in first and second CH.
failures in openssl ecparam and openssl crl.
CMS decryption.
violations.
TLSv1.2.
a deadlock.
in openssl(1).
returns 1. It has long been documented that this is ill advised
but some applications still do it.
abort the handshake with illegal_parameter.
handle sequences and sets in config parsing.
without breaking the RPKI. Still allow the immediate issuer to
omit one of the extensions because otherwise about one third of
RFC 9286 Manifests would become invalid.
saltlen restrictions are copied rather than using the defaults.
chain to make name constraints check work more reliably.
common names.
essentially unused legacy NAME_CONSTRAINTS_*() API.
Point extension. Per RFC 5280 it SHOULD not be used by conforming
CAs and it was eating memory for breakfast pre-signature.
Security and reliability fixes
Handle IPv6 literals correctly and don't allow specially crafted
userinfo to bypass host checks.
large memory consumption on small handshake message fragments.
tls_config_ocsp_require_stapling(), of which only OpenBSD nc(1)
and ftp(1) are known when they're used with the "muststaple" key
word.
Testing and proactive security
file based. Match Go's output format more closely.
Full changelog: https://github.com/libressl/portable/blob/v4.4.0/ChangeLog
v4.3.4Compare Source
Security fix
Full changelog: https://github.com/libressl/portable/blob/v4.3.4/ChangeLog
v4.3.3Compare Source
Portable changes
constant-time bignum code.
handle.
Security and reliability fixes
mismatch
Full changelog: https://github.com/libressl/portable/blob/OPENBSD_7_9/ChangeLog
v4.3.2Compare Source
Portable Changes
Bug fixes
cert chains again.
Full changelog: https://github.com/libressl/portable/blob/master/ChangeLog
v4.3.1Compare Source
Portable Changes
Full changelog: https://github.com/libressl/portable/blob/master/ChangeLog
v4.3.0Compare Source
Internal improvements
misleading use of ntohs() with htons().
The API will be removed in an upcoming release.
curve a given EC_POINT is supposed to live.
in various EC API. This isn't 100% failsafe but good enough for sane
uses.
On rare i386 machines suporting MMX but not SSE this could result
in an illegal instruction.
using C99 initializers in particular.
those from RFC 7919). Some projects still fiddle with this in 2025.
cannot be removed since one scripting language still exposes it.
than relying on i2c_ASN1_BIT_STRING() to do that when encoding.
to avoid warnings when compiling with OpenSSL 4.
links.
handling, disable TLSv1.1 and lower also on the method level.
semantics by direct reaching into deeply nested OCSP structures.
Compatibility changes
Fixes long-standing issues with 32-bit longs on 64-bit Windows.
BN_LONG, BN_BITS{,4}, BN_MASK2{,l,h,h1}, BN_TBIT, BN_DEC_CONV,
BN_{DEC,HEX}_FMT{1,2}, ...
-uncompress switches.
behavior but some language bindings decided to rely on it in 2025.
still one user...
The adb_cb() argument is currently ignored.
New features
https://datatracker.ietf.org/doc/draft-ietf-tls-ecdhe-mlkem/
Bug fixes
HelloRetryRequest is not one for which the client has
already sent a key share.
legacy primitives in openssl(1) speed.
ASN1_STRING_FLAG_BITS_LEFT is not set.
in PKCS#12 parsing.
certs.
config parsing.
like all other openssl(1) subcommands.
missing. This is flagged on deserialization, but nothing checks
that flag. This can lead to a NULL dereference if the verification
has enabled Delta CRL checking by setting X509_V_FLAG_USE_DELTAS.
parameter encoding for CMS decryption.
unrelated errnos.
match exactly and allow zero or more components in front of
the candidate.
Reliability fix
lead to a 4-byte overwrite on heap allocated memory for clients
talking to a malicious server or for servers that have client
certificate verification enabled. In addition, the maximum depth
must be set to the maximum allowed value of 32.
Thanks to Calif.io in collaboration with Claude and Anthropic
Research, for reporting the issue.
Testing and proactive security
and correctness. Add tests for ML-KEM in particular.
Full changelog: https://github.com/libressl/portable/blob/master/ChangeLog
v4.2.3Compare Source
Security fix
Full changelog: https://github.com/libressl/portable/blob/v4.2.3/ChangeLog
v4.2.2Compare Source
Portable changes
constant-time bignum code.
handle.
Security and reliability fixes
mismatch
Full changelog: https://github.com/libressl/portable/blob/OPENBSD_7_8/ChangeLog
Configuration
📅 Schedule: (UTC)
🚦 Automerge: Disabled by config. Please merge this manually once you are satisfied.
♻ Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.
🔕 Ignore: Close this PR and you won't be reminded about this update again.
This PR was generated by Mend Renovate. View the repository job log.