granite: update blocked by GTK4 (>= 4.12) #187
Description
| Field | Value |
|---|---|
| Package | granite |
| Current | 6.2.0 |
| Blocked by | GTK4 (gtk4 >= 4.12) |
While this Issue is open, build-package refuses to bump granite (doc/spec.md 4.7). Close it once the blocker is resolved.
Why
Every granite 7.x release requires GTK4, and 6.2.0 is the last release on GTK3 (the tag after it is 7.0.0):
- 7.0.0:
dependency('gtk4', version: '>=4.4') - 7.8.1:
dependency('gtk4', version: '>=4.12')
No Cygwin package provides gtk4.pc. The Cygwin mirror only has GTK up to libgtk3-devel 3.24.52, and neither yacp-dev/ports nor dist.yacp.dev has GTK4 at all.
sequeler and switchboard in yacp-dev/ports build against libgranite-devel together with libgtk3-devel, so replacing the GTK3 granite with 7.x would affect them. Many distros keep 6.2.0 and package 7.x separately (granite7, granite-7).
To unblock
- Get GTK4 >= 4.12 into the Cygwin mirror, or port it to yacp-dev/ports and publish it on dist.yacp.dev.
- Decide what happens to
sequelerandswitchboard: port them to granite 7, or package granite 7 alongside 6.2.0. - Close this Issue.
- Bump granite: move
BUILD_REQUIRESfromlibgtk3-develto the GTK4 package, and recheck the package contents (the runtime package and the GIR package are named after granite 6, and 7.x setsgranite_gi_version = '7.0').
Found by: no build was attempted for 7.8.1; the requirement was read from upstream's meson.build. The GTK3 granite was rebuilt as 6.2.0-1bl2 in yacp-dev/ports#556.
Activity